Error Installation

cPanel plugin for php selection
Post Reply
fanny.oyarzun
Posts: 0
Joined: Thu May 12, 2016 8:14 pm

Error Installation

Post by fanny.oyarzun »

Hi, I have an error in the installation of ntphpselector. Deputy details of my server:

php-5.2.17/build/buildcheck.sh
php-5.2.17/build/print_include.awk
php-5.2.17/build/order_by_dep.awk
php-5.2.17/build/mkdep.awk
php-5.2.17/build/shtool
php-5.2.17/build/build2.mk
php-5.2.17/build/libtool.m4
php-5.2.17/build/scan_makefile_in.awk
php-5.2.17/php5.spec.in
php-5.2.17/genfiles
php-5.2.17/README.SUBMITTING_PATCH
php-5.2.17/server-tests.php
php-5.2.17/buildconf.bat
php-5.2.17/stub.c
--2016-05-12 10:45:25-- https://www.nixtree.com/download/free/n ... tch.tar.gz
Resolviendo www.nixtree.com... 198.235.134.108
Connecting to www.nixtree.com|198.235.134.108|:443... conectado.
Petición HTTP enviada, esperando respuesta... 200 OK
Longitud: 60544 (59K) [application/x-gzip]
Saving to: `2_17.pm.patch.tar.gz'

100%[====================================================================================================================================================>] 60.544 144K/s in 0,4s

2016-05-12 10:45:26 (144 KB/s) - `2_17.pm.patch.tar.gz' saved [60544/60544]

php5-concurrent.patch
php5-binary-rename.patch
php5-use_embedded_timezonedb.patch
php5-png_check_sig.patch
php5-CVE-2011-4885.patch
php5-libxml.patch
php5-freebsd-ldflags.patch
php5-ming-0.4.2.patch
php5-iconv-ldflags.patch
php5-conftest-tmpnam.patch
php5-fixed-lib64.patch
php5-mail-header.patch
php5-CVE-2012-0830.patch
patching file configure
patching file configure
patching file main/main.c
Hunk #1 succeeded at 436 (offset 1 line).
patching file main/php_globals.h
Hunk #1 succeeded at 160 with fuzz 2.
patching file main/php_variables.c
patching file main/php_variables.c
patching file configure
patching file acinclude.m4
patching file aclocal.m4
patching file configure
Hunk #388 FAILED at 109428.
1 out of 396 hunks FAILED -- saving rejects to file configure.rej
patching file configure.in
patching file configure
patching file ext/dom/documenttype.c
Hunk #1 succeeded at 215 (offset 10 lines).
patching file ext/dom/node.c
Hunk #1 succeeded at 1950 (offset 55 lines).
patching file ext/simplexml/simplexml.c
Hunk #1 succeeded at 1343 (offset -44 lines).
patching file ext/standard/mail.c
patching file ext/ming/ming.c
patching file ext/ming/php_ming.h
patching file ext/gd/libgd/gd_png.c
patching file ext/date/lib/parse_tz.c
Hunk #3 succeeded at 228 (offset 6 lines).
Hunk #4 succeeded at 695 (offset 6 lines).
Hunk #5 succeeded at 817 (offset 6 lines).
configure: error: can only configure for one host and one target at a time
COMPILE ERROR FOR 52
Exiting Installation
/bin/cp: no se puede efectuar `stat' sobre «/usr/local/apache/conf/includes/pre_main_global.conf.ntphp.bak»: No existe el fichero o el directorio
«/opt/suphp/etc/suphp.conf.ntphp.bak» -> «/opt/suphp/etc/suphp.conf»
Please open a new thread at http://nixtree.com/forum/ if you meet with any issues

Details Server:

#### grep '' /etc/redhat-release /usr/local/cpanel/version /var/cpanel/envtype ; grep CPANEL= /etc/cpupdate.conf ;
/etc/redhat-release:CentOS release 6.7 (Final)
/usr/local/cpanel/version:11.54.0.23
/var/cpanel/envtype:kvm
CPANEL=stable

#### httpd -v ; php -v ; mysql -V ;arch ;
Server version: Apache/2.2.31 (Unix)
Server built: May 12 2016 09:31:36
Cpanel::Easy::Apache v3.32.13 rev9999
PHP 5.4.45 (cli) (built: May 12 2016 09:36:10)
Copyright (c) 1997-2014 The PHP Group
Zend Engine v2.4.0, Copyright (c) 1998-2014 Zend Technologies
with the ionCube PHP Loader (enabled) + Intrusion Protection from ioncube24.com (unconfigured) v5.1.1, Copyright (c) 2002-2016, by ionCube Ltd.
with Suhosin v0.9.38, Copyright (c) 2007-2015, by SektionEins GmbH
mysql Ver 14.14 Distrib 5.5.48, for Linux (x86_64) using readline 5.1
x86_64

#### php –m
[PHP Modules]
bcmath
calendar
Core
ctype
curl
date
dom
ereg
filter
ftp
gd
hash
iconv
imap
ionCube Loader
json
libxml
mcrypt
mysql
mysqli
mysqlnd
openssl
pcre
PDO
pdo_mysql
pdo_sqlite
pgsql
Phar
posix
Reflection
session
SimpleXML
snmp
sockets
SPL
sqlite3
standard
suhosin
tidy
tokenizer
xml
xmlreader
xmlwriter
zip
zlib

[Zend Modules]
the ionCube PHP Loader (enabled) + Intrusion Protection from ioncube24.com (unconfigured)

####/usr/local/cpanel/bin/rebuild_phpconf --current

Available handlers: suphp dso cgi none
DEFAULT PHP: 5
PHP4 SAPI: none
PHP5 SAPI: suphp
SUEXEC: enabled
RUID2: not installed



sreepriya
Posts: 0
Joined: Fri Sep 16, 2016 12:48 pm

Re: Error Installation

Post by sreepriya »

Do you need php 5.2 version or just other versions ? If you need 5.2 version, then you might need to contact support team and see if they can install manually and get it incorporated in the ntphp selector and install other versions.

They do have a paid support which I got it working which will cost $40 one time setup cost. So select the latest available php version via easy apache and then setup the rest of the versions via ntphp which will be the best I guess



Edward
Posts: 24
Joined: Mon May 04, 2015 10:16 am

Re: Error Installation

Post by Edward »

ntPHPselector version 4.1.0 RELEASED

New version of ntPHPselector with 5.3 support is released. It has a WHM module for recompilation of 5.3 and
listing the instances of custom php used.

URL : https://www.nixtree.com/nt-php-selector.php


Features

[+] Added 5.3 Support.
[+] WHM Interface available for listing the instances of custom PHP used.
[+] 5.3 Recompilation option available via WHM interface.
[+] Recompilation logs can be view from the WHM interface
[+] Compatible with Centos 6 and Centos 7.

The php version 5.3 successfully recompiled with Centos 6 and Centos
7 operating systems. Missing of some devel packages or any other
custom environments in the server may cause the failure of php
recompile. And we suggest to do the troubleshoot in recompilation with
the help of an experienced hand. For recompilation and installation
support, please open a ticket with our support
[https://nixtreesupport.com/].

The yearly subscription for the ntPHPselector plugin is increased to
$12 and you can upgrade to the new version by paying the rest of the
amount. If you need upgrade, please reply to this mail.

Thank you,
Nixtree Solutions - Plugins & Development
https://www.nixtree.com


Edward N
Support Staff
Nixtree Solutions
Managed Backups || Server Management

https://www.nixtree.com

Post Reply