Installation error

cPanel plugin for php selection
f5host
Posts: 0
Joined: Wed Apr 20, 2016 5:54 pm

Installation error

Post by f5host »

Hello when I install'm having trouble error compiler 52

Could help this error



php5-concurrent.patch
php5-binary-rename.patch
php5-use_embedded_timezonedb.patch
php5-png_check_sig.patch
php5-CVE-2011-4885.patch
php5-libxml.patch
php5-freebsd-ldflags.patch
php5-ming-0.4.2.patch
php5-iconv-ldflags.patch
php5-conftest-tmpnam.patch
php5-fixed-lib64.patch
php5-mail-header.patch
php5-CVE-2012-0830.patch
patching file configure
patching file configure
patching file main/main.c
Hunk #1 succeeded at 436 (offset 1 line).
patching file main/php_globals.h
Hunk #1 succeeded at 160 with fuzz 2.
patching file main/php_variables.c
patching file main/php_variables.c
patching file configure
patching file acinclude.m4
patching file aclocal.m4
patching file configure
Hunk #388 FAILED at 109428.
1 out of 396 hunks FAILED -- saving rejects to file configure.rej
patching file configure.in
patching file configure
patching file ext/dom/documenttype.c
Hunk #1 succeeded at 215 (offset 10 lines).
patching file ext/dom/node.c
Hunk #1 succeeded at 1950 (offset 55 lines).
patching file ext/simplexml/simplexml.c
Hunk #1 succeeded at 1343 (offset -44 lines).
patching file ext/standard/mail.c
patching file ext/ming/ming.c
patching file ext/ming/php_ming.h
patching file ext/gd/libgd/gd_png.c
patching file ext/date/lib/parse_tz.c
Hunk #3 succeeded at 228 (offset 6 lines).
Hunk #4 succeeded at 695 (offset 6 lines).
Hunk #5 succeeded at 817 (offset 6 lines).
configure: error: can only configure for one host and one target at a time
COMPILE ERROR FOR 52
Exiting Installation
/bin/cp: cannot stat `/usr/local/apache/conf/includes/pre_main_global.conf.ntphp .bak': No such file or directory
/bin/cp: cannot stat `/opt/suphp/etc/suphp.conf.ntphp.bak': No such file or dire ctory
Please open a new thread at http://nixtree.com/forum/ if you meet with any issu es



Edward
Posts: 24
Joined: Mon May 04, 2015 10:16 am

Re: Installation error

Post by Edward »

We need the below details so that we can start debugging, update the forum with the details

( Note : Pease replace the IP and important information from the post )

Run the following commands and update the forum with the output.;

grep '' /etc/redhat-release /usr/local/cpanel/version /var/cpanel/envtype ; grep CPANEL= /etc/cpupdate.conf ;
httpd -v ; php -v ; mysql -V ;arch ;
php –m
/usr/local/cpanel/bin/rebuild_phpconf --current



f5host
Posts: 0
Joined: Wed Apr 20, 2016 5:54 pm

Re: Installation error

Post by f5host »

-bash-4.1# grep '' /etc/redhat-release /usr/local/cpanel/version /var/cpanel/envtype ; grep CPANEL= /etc/cpupdate.conf ;
/etc/redhat-release:CentOS release 6.7 (Final)
/usr/local/cpanel/version:11.54.0.21
/var/cpanel/envtype:standard
CPANEL=release
-bash-4.1# ^C
-bash-4.1# httpd -v ; php -v ; mysql -V ;arch ;
Server version: Apache/2.4.18 (Unix)
Server built: Apr 23 2016 14:13:50
Cpanel::Easy::Apache v3.32.12 rev9999
PHP 5.4.45 (cli) (built: Apr 23 2016 14:17:45)
Copyright (c) 1997-2014 The PHP Group
Zend Engine v2.4.0, Copyright (c) 1998-2014 Zend Technologies
with eAccelerator v0.9.6.1-ea, Copyright (c) 2004-2012 eAccelerator, by eAccelerator
with the ionCube PHP Loader (enabled) + Intrusion Protection from ioncube24.com (unconfigured) v5.1.1, Copyright (c) 2002-2016, by ionCube Ltd.
with Zend Guard Loader v3.3, Copyright (c) 1998-2013, by Zend Technologies
with Suhosin v0.9.36, Copyright (c) 2007-2014, by SektionEins GmbH
mysql Ver 14.14 Distrib 5.6.29, for Linux (x86_64) using EditLine wrapper
x86_64
-bash-4.1# php –m
Could not open input file: –m
-bash-4.1# /usr/local/cpanel/bin/rebuild_phpconf --current
Available handlers: suphp dso fcgi cgi none
DEFAULT PHP: 5
PHP4 SAPI: none
PHP5 SAPI: suphp
SUEXEC: enabled
RUID2: not installed



Edward
Posts: 24
Joined: Mon May 04, 2015 10:16 am

Re: Installation error

Post by Edward »

For Centos 6 :
cd /usr/local/src
wget -N https://nixtree.com/download/free/ntphp ... ge_beta.sh
sh ntphpselector_manage_beta.sh install

#For updating currently installed ntPHPselector using the following command;
sh ntphpselector_manage_beta.sh update

Did you used these ?


Edward N
Support Staff
Nixtree Solutions
Managed Backups || Server Management

https://www.nixtree.com

f5host
Posts: 0
Joined: Wed Apr 20, 2016 5:54 pm

Re: Installation error

Post by f5host »

configure: error: can only configure for one host and one target at a time
COMPILE ERROR FOR 52
Exiting Installation
/bin/cp: cannot stat `/usr/local/apache/conf/includes/pre_main_global.conf.ntphp.bak': No such file or directory
`/opt/suphp/etc/suphp.conf.ntphp.bak' -> `/opt/suphp/etc/suphp.conf'
Please open a new thread at http://nixtree.com/forum/ if you meet with any issues
-bas



f5host
Posts: 0
Joined: Wed Apr 20, 2016 5:54 pm

Re: Installation error

Post by f5host »

Hello yes Today try again from that same mistake



fanny.oyarzun
Posts: 0
Joined: Thu May 12, 2016 8:14 pm

Re: Installation error

Post by fanny.oyarzun »

Hello,
I get the same error How have you solved ?



redhat_boy
Posts: 0
Joined: Thu Jun 02, 2016 5:09 pm

Re: Installation error

Post by redhat_boy »

Hello,

I get the same error too. Can someone share the fix for it?.

Regards.



User avatar
GazCBG
Posts: 0
Joined: Sun May 29, 2016 12:45 am

Re: Installation error

Post by GazCBG »

Hi,

I too have the COMPILE ERROR FOR 52 error, when trying to install.
Any ideas on how to fix this, as it would be great if I could get it installed.



Edward
Posts: 24
Joined: Mon May 04, 2015 10:16 am

Re: Installation error

Post by Edward »

Hi

In a server centos 6 we tried and it is working fine. So not sure what the issue with each of these servers and needs to fix one at a time as sometimes can be due to some other librabries used by you and the versions used by those can be an issue.


Edward N
Support Staff
Nixtree Solutions
Managed Backups || Server Management

https://www.nixtree.com

Post Reply